Nexmo Stitch iOS SDK

CocoaPods CocoaPods CocoaPods Swift Carthage compatible Swift Package Manager compatible Documentation Twitter

The SDK is intended to provide a ready solution for developers who want to integrate chat, voice and video into their apps.

Getting started👇

Come checkout the iOS quickstarts!

Installation

CocoaPods

A dependency manager for Cocoa projects. You can install it with the following command:

$ gem install cocoapods

Integrate Nexmo Stitch into your project using CocoaPods, specify SDK in your Podfile:

source 'https://github.com/CocoaPods/Specs.git'

target '<YOUR_TARGET_NAME>' do
    pod 'Nexmo-Stitch'
end

Then, run the following command:

$ pod install --repo-update

Use SDK, add the following: Swift: import Stitch Objective-c: @import Stitch; 🎉🎉🎉

Documentation

Check out iOS API Reference!

Raw .html files and Dashset can be found the Docs folder.

License

Copyright © 2018 Nexmo, Inc. All rights reserved. Licensed only under the Nexmo Stitch SDK License Agreement (the License) located at

By downloading or otherwise using our software or services, you acknowledge that you have read, understand and agree to be bound by the Nexmo Stitch SDK License Agreement and Privacy Policy.

You may not use, exercise any rights with respect to or exploit this SDK, or any modifications or derivative works thereof, except in accordance with the License.

Author